#1 2017-04-19 16:14:11

Journey_Over
Member
Registered: 2015-06-02
Posts: 15

Your current settings might not be compatible with DirectX capture..

Dunno what exactly is happening but I recently got back into playing RS after being gone for the past year and for some reason I can't get Alt1 to recognize RS correctly...      [ This is all running on NXT / Windows 10 x64bit ]

Whenever I go into the settings for Alt1 it just throws this message up in the capture screen http://i.imgur.com/AMKGoD3.png

idk what settings could be messing this up any but hoping to get some help in figuring this out.

My Current RS Settings
http://i.imgur.com/ib3GeV6.png

My current in-game UI set up
http://i.imgur.com/6vihUx5.jpg

Could it be because I'm running compressed textures, or alt1 isn't compatible completely with the creators update of windows 10 or something?

I've checked my NVIDIA settings and to make sure everything was set to Application Controlled, and I tried running the game full screen and windowed, and I've tried running the the launcher/client as admin but nothing fixes it.
Alt1 detects the linked window, and when I turn on "Draw pixel detection debug data on the screen" it puts a red box around the game and a red rectangle around my right clicks in game.

Edit: and just minutes after posting about this, I fixed my issue... Decided to try and run everything in admin mode to do with RS and Alt1 and switched over to OpenGL instead of DirectX and things started working.

Last edited by Journey_Over (2017-04-19 16:26:20)

Offline

#2 2017-04-19 16:25:48

Skillbert
Administrator
Registered: 2014-12-30
Posts: 690

Re: Your current settings might not be compatible with DirectX capture..

Have you tried opengl or desktop capture? It should troubleshoot/toggle this automatically when you use some Alt1 features (pressing alt+1 or opening an app). It's fairly common that directX capture doesn't work, it depends on a lot of things like your graphics card, os, drivers etc. That's why there is opengl capture.

Offline

#3 2017-04-19 16:45:56

Journey_Over
Member
Registered: 2015-06-02
Posts: 15

Re: Your current settings might not be compatible with DirectX capture..

Skillbert wrote:

Have you tried opengl or desktop capture? It should troubleshoot/toggle this automatically when you use some Alt1 features (pressing alt+1 or opening an app). It's fairly common that directX capture doesn't work, it depends on a lot of things like your graphics card, os, drivers etc. That's why there is opengl capture.


I got it fixed through OpenGL capture, I honestly dunno why DirectX capture stopped working for me as it was working a few days ago just fine on DirectX capture mode and I haven't changed anything or downloaded anything on my PC any that would of caused it to stop working, but I guess it doesn't matter much now since OpenGL is working now for the time being. (just hoping it doesn't break on me as well at some point >..<)

Offline

#4 2017-04-22 20:13:26

XZeenon
Member
Registered: 2016-07-21
Posts: 17

Re: Your current settings might not be compatible with DirectX capture..

Same issue here, except, OpenGL tends to not work sometimes as well...  I have the newest drivers for my NVIDIA GeForce GTX 970.

Offline

#5 2017-04-30 17:45:03

Journey_Over
Member
Registered: 2015-06-02
Posts: 15

Re: Your current settings might not be compatible with DirectX capture..

XZeenon wrote:

Same issue here, except, OpenGL tends to not work sometimes as well...  I have the newest drivers for my NVIDIA GeForce GTX 970.


True, running into it not working on OpenGL now as well so currently at a complete loss on what to do since I've already exhausted all my previous attempts at getting it to work again..

Offline

Quick reply

Write your message and submit

Board footer

Powered by FluxBB