#1 2015-07-04 13:33:36

Skillbert
Administrator
Registered: 2014-12-30
Posts: 1,001

Image detection problems with 1.1.0

UPDATE: I just released version 1.1.1 which has a compatibility mode that reverts the pixel grabbing update. You can find it under settings > other.

UPDATE 2: Version 1.1.2 is released now which automatically enables compatibility mode when required.

Release 1.1 changed the way that image capture works, a lot of people are reporting that it doesn't work anymore for them. Please use this thread to get the reports in one place with some more vital information.

  1. Make sure the rs client is detected by Alt1. The Alt1 icon will turn gray when the rs client is not found. It should look like this ttt.png

  2. If the icon is colored, and image detection is still not working, please post a reply on this thread with the following information (don't need an account)

    • Version of windows?

    • Did it work on the previous release?

    • If using windows 7, are window borders transparent with a glass look?

    • What message does the failing app display? (if any)

In the short term i will make the following changes:

  • Browsers with the right text in the title will be detected as rs again.

  • Some more error detection to give a meaningful error information when things go wrong.

This update is required to support windows 8.1 with high dpi displays, which are becoming more and more common, and will be the standard at some point. It also makes image capture a lot quicker, capturing an image twice a second would cause noticeable lag before. 200+ works fine now. The new capturing method also allows alt1 to see rs without it being visible on the screen.

Last edited by Skillbert (2015-08-30 19:39:41)

Offline

#2 2015-07-04 14:09:07

Ronan
Guest

Re: Image detection problems with 1.1.0

My Runescape client is detected by the Alt1 App.
Windows version: vista
Did it work on previous release: yes
The failing app displays the message: Map not found. Please make sure the full dungeon map is visible on your screen. (which it is)

Thank you for all your effort, the app is great!!

#3 2015-07-04 19:32:11

ensilvade
Guest

Re: Image detection problems with 1.1.0

I believe my alt1 app icon in the taskbar is always colored, even when I don't have the client open.  It was working before the update

Windows 8.1, 1440p monitor since you were talking about higher dpi displays.

Used the clue scroll solver all the time, now it doesnt detect any clue open, slide puzzle or celtic knot.

#4 2015-07-05 01:32:46

Skillbert
Administrator
Registered: 2014-12-30
Posts: 1,001

Re: Image detection problems with 1.1.0

Ronan, are the borders of the windows glass-like and transparent of opaque?

Offline

#5 2015-07-05 16:49:17

Ronan
Guest

Re: Image detection problems with 1.1.0

Skillbert, I'm not sure which windows you mean. If you are talking about the entire client/browser windows, then here is what they look like:

http://puu.sh/iO3pY/295ef2c7d3.png

They aren't glass-like or transparent

#6 2015-07-22 23:23:50

Matty
Guest

Re: Image detection problems with 1.1.0

Windows 7 Ultimate x64
This is the first time i've used this program
Yes the windows are transparent. Aero is on.
display is 1920x1080

There is no error message. Nothing will work though. Xptracker stuck on "Searching". Alt-1 on players/items/monsters doesn't work. Treasure Trails doesn't work. Basically. anything that scans the screen doesn't work.

#7 2015-07-23 10:09:54

Skillbert
Administrator
Registered: 2014-12-30
Posts: 1,001

Re: Image detection problems with 1.1.0

Is compatibly mode turned on? you can change this in the settings under the "other" tab. And can you make screenshots with the alt+2 feature?

Offline

#8 2015-08-29 15:58:42

anthonyors
Guest

Re: Image detection problems with 1.1.0

Version of windows?  windows 7
Did it work on the previous release?i used this on other computer i have and it works great
If using windows 7, are window borders transparent with a glass look?the boarders are glassy looging and i can see my wallpaper threw the boarders
What message does the failing app display? the message says no puzzle or clue detected make sure the client has a puzzle open
thank you so much for this wonderful app please try ur best to help me figure this out! i cant clue without it haha big_smile thanks!---ant!---

#9 2015-08-29 16:05:31

anthonyors
Guest

Re: Image detection problems with 1.1.0

sorry and yes the app detects rs client but just dont see the clues i guess

#10 2015-08-29 19:15:50

Skillbert
Administrator
Registered: 2014-12-30
Posts: 1,001

Re: Image detection problems with 1.1.0

This problem has mostly been solved in 1.1.2 now. It should automatically toggle to compat mode if the new mode doesn't work. You can see the current mode in the settings under the "other" tab.

If the problem still remain on compat mode can you send me a screenshot of the puzzle by pressing alt+2?
Something like this (I don't have an actual puzzle right now)
http://runeapps.org/i/353.png

Offline

#11 2015-08-29 20:21:33

anthonyors
Guest

Re: Image detection problems with 1.1.0

skillbert im in the alt1 settings < other  ---says alt1 version: 1.1.2    chromium version  39.0.2171.95 this is the version ive had since i downloaded this a few hours ago.... can it be something to do with my boarder thing being like glassy looking??? i may just not understand what ur wanting me to do with it i had to log on to other computer to do the clue cause the app works on there... im trying my best to get it to work and appreciate all the help that your giving me message back when you get a chance -------- ant--------

#12 2015-08-29 20:25:58

anthonyors
Guest

Re: Image detection problems with 1.1.0

one more thing is there another version that may solve this problem? thanks!

#13 2015-08-29 20:34:05

anthonyors
Guest

Re: Image detection problems with 1.1.0

ok it just found the map of dung so gimme a few mins ima try to get an elite fast n ill let ya know the results thanks!!!

#14 2015-08-29 20:45:50

anthonyors
Guest

Re: Image detection problems with 1.1.0

welp got me another clue and its working some how now smile thanks man alot! awesome app for the community ----question----this is legal by jagex right?----

#15 2015-08-30 09:49:37

Nawsen
Administrator
Registered: 2015-05-22
Posts: 36

Re: Image detection problems with 1.1.0

anthonyors wrote:

----question----this is legal by jagex right?----

Yes Alt1 toolkit is perfectly legal.
Alt1 only looks at your screen to get information, which is not against the rules.

Offline

#16 2015-08-30 19:45:15

Skillbert
Administrator
Registered: 2014-12-30
Posts: 1,001

Re: Image detection problems with 1.1.0

Just closed this topic as it's now outdated. This problem was fixed with 1.1.2 (currently latest release).

The glassy border thing tells me that you have windows Aero enabled, which makes image capture a lot better.

Offline

Board footer

Powered by FluxBB