#1 2023-12-20 00:52:16

crazye97
Member
Registered: 2019-03-19
Posts: 232

ARE YOU HAVING ISSUES RECENTLY? SEE HERE FIRST.

From the recent engine update:

Skillbert wrote:

With todays update jagex changed the way that interface scaling works. If you are using display scaling in windows then Alt1 will no longer works for you. This is most likely the case if you have a 4K, 1444p or modern laptop screen.

You can revert RuneScape to how it was last week by changing settings in Windows:

  1. Go to C:\ProgramData\Jagex\launcher (this is a hidden folder, copy-paste the address)
      - for the steam client go to C:\Program Files (x86)\Steam\steamapps\common\RuneScape\launcher

  2. Rightclick rs2client.exe and click properties

  3. Go to the Compatibility tab and click Change high DPI settings

  4. Click the Override High DPI scaling behavior and set the dropdown to system

  5. Click OK

  6. Click apply on the properties window

After this restart your RuneScape client and everything should work again.

c3J1IR4.png

If the above doesn't work, try this.

Note that, without this fix, the engine update made it so RS factors both the in-game Interface Scaling setting and external scaling options, ie. Windows. This means that a total of 100% is needed - whether that means 100% in-game and 100% external, 80% in-game and 125% external, etc.

As well, if the game is blurry after doing this, make sure the Game Render and UI scaling settings in-game are both set to 100%. If there's alignment issues, or if you're playing on a high-resolution monitor (ie. 2K, 4K, etc.), check the main Alt1 settings and toggle/untoggle the Override high DPI scaling detection option to see if it helps.

Last edited by crazye97 (2024-03-09 12:07:33)

Offline

#2 2024-01-21 04:42:28

jsgh205
Member
Registered: 2019-01-14
Posts: 10

Re: ARE YOU HAVING ISSUES RECENTLY? SEE HERE FIRST.

omg thank you it worked, wish i had solved it before while I was getting the birthday event clue reward boosts this past week. But thank you so much.

Offline

#3 2024-03-10 12:17:35

sethnzen
Member
Registered: 2024-03-10
Posts: 2

Re: ARE YOU HAVING ISSUES RECENTLY? SEE HERE FIRST.

ok so i decided to try the program out, but cant get it to work, every alt1 app i try to use starts up a little blank white app window overlay in rs3, lasts for about a second or two then the whole alt1 client closes out.
no options on the top right part of the bar, nothing.
ive tried what you have here and it didnt work, tried reinstalling. cant seem to find anything online to point me in the right direction.
i will say the screenshot setting through alt1 works great but thats the only feature thats working.
i did read somewhere that using a laptop can be an issue, and thats what im on. its an acer laptop.
nothing fancy. i even tried messing with the laptop itselfs scaling settings, no luck.

Offline

#4 2024-03-10 12:42:57

Skillbert
Administrator
Registered: 2014-12-30
Posts: 1,059

Re: ARE YOU HAVING ISSUES RECENTLY? SEE HERE FIRST.

@senthnzen, sounds like this issue https://runeapps.org/forums/viewtopic.php?id=1523

Offline

#5 2024-03-11 22:42:52

nachtbakker
Member
Registered: 2024-03-11
Posts: 1

Re: ARE YOU HAVING ISSUES RECENTLY? SEE HERE FIRST.

With me there is actually online 5 buttons at the top, the compatibility button does not appear at all?

Offline

Board footer

Powered by FluxBB